Device Requirements

Android

RoadWarrior is compatible with Android devices running Android 5.0 (initial release 2014) or higher.

Learn how to check and update your Android version with Google’s instructions.

iOS

RoadWarrior is compatible with Apple devices running iOS 10.0 (initial release 2016) or higher.

Learn how to check your iOS version and update your iOS version with Apple’s instructions.

Web

We recommend running RoadWarrior web programs in Google Chrome or Mozilla Firefox, as browsers such as Internet Explorer or Microsoft Edge cannot support our functionality at this time.